Forum Imprimante

 Oublié Pass?
 Register
Rechercher
Voir: 227|Réponse: 16

imprimante canon et scanner

[Copier lien]

Post sur le : 2012-07-10 14:12:00 |Tout les posts
Bonjour, je n'arrive pas à scanner avec mon imprimantes canon pixma mp280
J'ai installé scangear car xsane ne reconnaît pas les scanner canon. Mais quand je lance scangear, il me met " impossible de trouver les scanners disponible " alors que l'imprimante est branchée et communique avec l'ordinateur puisque je peux photocopier.
Merci d'avance pour toutes vos réponse
Réponse

Accessoires Signaler

Post sur le : 2012-07-10 15:17:59 |Tout les posts
Bonjour,
Xsane ne prends pas en charge les scanners des multifonction de la serie MPxxx de chez Canon. La prochaine version xsane (encore en développement) devrait les prendre en charge. En attendant, il faut se servir de l'outils inclus dans ubuntu : outils de numérisation simple scan.
Cdt.
Réponse

Accessoires Signaler

Post sur le : 2012-07-10 16:47:35 |Tout les posts
Simple scan me dit qu'il ne détecte pas de scanner. C'est sa que je ne comprend pas aucun logiciel de numérisation pour ubuntu ne détecte mon scanner. Quand je suis sous windows je peux scanner donc l'erreur vient des logiciels et non du scanner.
Cdt
Réponse

Accessoires Signaler

Post sur le : 2012-07-10 18:29:57 |Tout les posts
oui mais le problème est toujours le même, Xsane me dit que aucun scanner n'est branché
Réponse

Accessoires Signaler

Post sur le : 2012-07-10 19:37:46 |Tout les posts
xsane ou simple-scan ne pourra pas voir votre scanner pour la simple et bonne raison qu'il n'est pas supporté par la version de sane installée avec Ubuntu 12.04. Pour pouvoir utiliser votre scanner avec xsane ou simple-scan il faut compiler la version de développement.
Réponse

Accessoires Signaler

Post sur le : 2012-07-10 21:37:12 |Tout les posts
Comment il faut faire ?
Réponse

Accessoires Signaler

Post sur le : 2012-07-10 22:57:59 |Tout les posts
- Installer les paquets libusb-dev et build-essentials
- Télécharger et extraire les sources de la dernière version en développement
- Compiler la librairie sane.
J'avais documenté l'installation de la mp560 sous Lucid (10.04). À l'époque le scanner n'était pas supporté et il était possible de l'utiliser en compilant la dernière version de Sane. Vous pouvez vous baser sur cette doc : http://doc.ubuntu-fr.org/imprimante_can … imple-scan
S'il y a des choses que vous ne comprenez pas dans la doc, n’hésitez pas à revenir poser des questions avant de vous lancer dans quoi que ce soit.
Pour finir, il faut savoir qu'étant donné que c'est une version en développement, le fonctionnement n'est pas garanti à 100%.
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 00:17:47 |Tout les posts
J'ai installé les paquets libusd-dev  et build-essentials
J'ai télécharger et extrait les sources de la dernière version en développement
J'ai enregistrer le dossier sane-backends-56db981 sur le bureau ( le chemin pour y accéder est /home/delbruel/bureau/sane-backends-56db981
Mais je ne comprends pas bien ce qu'il faut faire à l'étape 3,   d'après ta documentation : Depuis le dossier sane-backend-xxxxxx [...] saisissez dans un terminal:
Qu'est-ce qu'il faut que je tape précisément dans le terminal ?
Dsl de poser des question comme sa mais je suis un débutant

Réponse

Accessoires Signaler

Post sur le : 2012-07-11 02:09:40 |Tout les posts
Pour l'étape 3, il faut faire :
cd /home/delbruel/bureau/sane-backends-56db981
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
sudo make install
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 03:20:31 |Tout les posts
Après avoir compiler, je liste les scanners disponibles et j'obtiens
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 04:24:13 |Tout les posts
Houla, pas besoin de compiler (a moins pour un truc tres spécifique). En effet, Il y a des depots PPA "spécial canon MPxxx", Essaye le petit tuto que j'avais fait ici
Ps : Le tuto est pour une MP560, il devrait fonctionner pour une MP280, il faut juste changer les noms des paquet de MP560 en MP280...
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 06:06:02 |Tout les posts
[/b]Votre multifonction est connectée en USB? Elle est bien sous tension? Pouvez-vous donner également le retour de la commande
grep -iA1 mp280 /lib/udev/rules.d/40-libsane.rules
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 07:39:20 |Tout les posts
Voila ce que j'obtiens, rien.
L'imprimante est bien connecté en USB, et elle est bien sous tension vu que je peux imprimer sans problème.
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 08:43:36 |Tout les posts
Entrez cette commande puis redémarrez votre PC :
echo -e '# Canon PIXMA MP280\nATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1746", ENV{libsane_matched}="yes"' | sudo tee -a /lib/udev/rules.d/40-libsane.rules
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 10:06:54 |Tout les posts
J'ai entré cette commande puis j'ai redémarrer.
Ensuite j'ai entré dans le terminal  
  et il ne trouve toujours pas de scanner. Pour être sur, j'ai lancer une impression a partir de open office et il n'y a pas eu de problème.
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 11:53:01 |Tout les posts
Je suis allé voir ton tuto, pour les drivers de l’imprimante j'ai déjà trouvé et sa marche parfaitement. moi j'ai un problème pour le scanner.
Réponse

Accessoires Signaler

Post sur le : 2012-07-11 13:32:21 |Tout les posts
il me semble que le fait d'installer les fameux PPA règle aussi le probleme du scanner.... De toute façon si cela ne fonctionne pas il suffira de désintaller le paquet via synaptic ou dans un terminal a coup d'"apt-get remove"
Réponse

Accessoires Signaler

Vous devez vous connecter d'abord connect | Register

Contact Us| Archive| Forum Imprimante

GMT+1, 2014-10-23 09:35

Powered by Discuz! 7.2

Release 20121101, © 2001-2014 Forum Imprimante.

Top